<!DOCTYPE html>
<html lang="en-GB">
<head>
    <meta charset="utf-8" />
    <title>Fantasy Football: Three cheap FPL options who play twice in GW25 | GiveMeSport</title>
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=5">
    <meta name="application-name" content="GiveMeSport">
    <meta name="theme-color" content="#000000">
    <meta name="msapplication-config" content="/msconfig.xml">
    <meta name="apple-mobile-web-app-title" content="GiveMeSport">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-status-bar-style" content="black">
            <meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1">
        <meta name="description" content="It&#x27;s a small DGW but there&#x27;s still plenty of value...">
        <meta name="twitter:card" content="summary_large_image">
        <meta name="twitter:site" content="GiveMeSport">
        <meta name="twitter:creator" content="GiveMeSport">
        <meta name="keywords" content="fantasy,football,james ward-prowse,premier league,raphinha dias belloli,stuart dallas">
        <meta property="fb:pages" content="566760030037879">
        <meta property="fb:app_id" content="112285998808712">
        <meta property="og:site_name" content="GiveMeSport">
        <meta property="fb:admins" content="100000241027088">
        <meta property="og:type" content="article">
        <meta property="article:publisher" content="https://www.facebook.com/GiveMeSport/">
        <meta property="og:url" content="https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25">
        <meta property="og:title" content="Fantasy Football: Three cheap FPL options who play twice in GW25">
        <meta property="og:description" content="Fantasy Football: Three cheap FPL options who play twice in DGW25">
        <meta property="article:published_time" content="2021-02-19T09:03:36.4440000Z">
        <meta property="article:modified_time" content="2021-02-19T09:03:36.4440000Z">
        <meta property="article:tag" content="fantasy,football,james ward-prowse,premier league,raphinha dias belloli,stuart dallas">
        <meta property="article:section" content="Football">
        <meta property="article:author" content="https://www.givemesport.com/joe-willis">
        <meta property="og:image" content="https://site-cdn.givemesport.com/images/21/02/19/2afb5e17e842515d35e47aff7420a86a/960.jpg">
        <meta property="og:image:width" content="960">
        <meta property="og:image:height" content="620">
    <link rel="amphtml" href="https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25?amp" />

    <link rel="apple-touch-icon" sizes="60x60" href="https://site-cdn.givemesport.com/v4/icons/gms-60x60.png">
    <link rel="apple-touch-icon" sizes="76x76" href="https://site-cdn.givemesport.com/v4/icons/gms-76x76.png">
    <link rel="apple-touch-icon" sizes="120x120" href="https://site-cdn.givemesport.com/v4/icons/gms-120x120.png">
    <link rel="apple-touch-icon" sizes="152x152" href="https://site-cdn.givemesport.com/v4/icons/gms-152x152.png">
    <link rel="apple-touch-icon" sizes="167x167" href="https://site-cdn.givemesport.com/v4/icons/gms-167x167.png">
    <link rel="apple-touch-icon" sizes="180x180" href="https://site-cdn.givemesport.com/v4/icons/gms-180x180.png">
    <link rel="apple-touch-icon" sizes="512x512" href="https://site-cdn.givemesport.com/v4/icons/gms-512x512.png">
    <link rel="apple-touch-startup-image" sizes="2048x2732" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-2048x2732.png">
    <link rel="apple-touch-startup-image" sizes="1668x2224" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-1668x2224.png">
    <link rel="apple-touch-startup-image" sizes="1536x2048" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-1536x2048.png">
    <link rel="apple-touch-startup-image" sizes="1125x2436" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-1125x2436.png">
    <link rel="apple-touch-startup-image" sizes="1242x2208" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-1242x2208.png">
    <link rel="apple-touch-startup-image" sizes="750x1334" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-750x1334.png">
    <link rel="apple-touch-startup-image" sizes="640x1136" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-640x1136.png">
    <link rel="icon" type="image/png" sizes="32x32" href="https://site-cdn.givemesport.com/v4/icons/favicon-48x48.png">
    <link rel="icon" type="image/png" sizes="32x32" href="https://site-cdn.givemesport.com/v4/icons/favicon-32x32.png">
    <link rel="icon" type="image/png" sizes="16x16" href="https://site-cdn.givemesport.com/v4/icons/favicon-16x16.png">
    <link rel="shortcut icon" href="/favicon.ico">
    <link rel="manifest" href="/manifest.json">
    <link rel="preconnect" href="https://site-cdn.givemesport.com" crossorigin>
    <link rel="preconnect" href="https://www.google-analytics.com" crossorigin>
    <link rel="preconnect" href="https://www.googletagservices.com" crossorigin>
    <link rel="preconnect" href="https://www.facebook.com" crossorigin>
    <link rel="canonical" href="https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25">
    <!--Version Number: 0.0.635-master -->
    
    

	<link href="https://fonts.googleapis.com/css2?family=DM+Sans:wght@400;700&display=swap" rel="stylesheet">
    <style>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</style>
    <link rel="preload" href="/css/article.min.css?v=VEGc4v2mVQnmtD_ARtywpEu3g_eJuSqq6gTTNsF_6Kk" as="style" onload="this.onload = null; this.rel = 'stylesheet';">
    <noscript><link rel="stylesheet" href="/css/article.min.css?v=VEGc4v2mVQnmtD_ARtywpEu3g_eJuSqq6gTTNsF_6Kk"></noscript>


    
    
        <link rel="preload" href="/css/common.min.css?v=kBkx88VPR0EF78T1c0KNYmr2fC36IT-5Us5KUt4R0oM" as="style" onload="this.onload=null;this.rel='stylesheet'">
        <noscript><link rel="stylesheet" href="/css/common.min.css?v=kBkx88VPR0EF78T1c0KNYmr2fC36IT-5Us5KUt4R0oM"></noscript>
        <script>(function (w) { w.gms = { config: { enviro: "live" } }; }(this));</script>
    
    
    <script>
        (function (c) {
            c.author = "Joe Willis";
            c.authortype = ""; //TODO: Need on model
            c.channel = "Football";
            c.id = 1651815;
            c.pagetype = "editorial";
            c.sponsor = "";
            c.tag = ["Fantasy","Football","James Ward-Prowse","Premier League","Raphinha Dias Belloli","Stuart Dallas"];
            c.team = "";
            c.pubTime = "9-10";
            c.pubDate = "20210219";
            c.viewType = "Thumbnail";
        }(this.gms.config));
    </script>

    <script src="https://cdn.id5-sync.com/api/0.9/id5-api.js"></script>
    
    
        <script>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</script>
    

    <script async src="//js-sec.indexww.com/ht/p/190445-133507786892336.js"></script>
    <script>
        (function() {
            __tcfapi('addEventListener', 2, function(tcData,success){

                if(success && (tcData.eventStatus === 'tcloaded' || tcData.eventStatus === 'useractioncomplete')) {

                    if(tcData.gdprApplies){
                        if(tcData.tcString){
                            console.log('SUCCESS!');
                            console.log(tcData);

                            var el = document.createElement('script');
                            var fs = document.getElementsByTagName('script')[0];
                            var url = '//www.googletagservices.com/tag/js/gpt.js';

                            el.async = true;
                            el.type = 'text/javascript';
                            el.src = url;

                            fs.parentNode.insertBefore(el, fs);
                        }
                    } else {
                        //gdpr doesnt apply
                        var el = document.createElement('script');
                        var fs = document.getElementsByTagName('script')[0];
                        var url = '//www.googletagservices.com/tag/js/gpt.js';

                        el.async = true;
                        el.type = 'text/javascript';
                        el.src = url;

                        fs.parentNode.insertBefore(el, fs);
                    }
                }    
            });
        })();
    </script>

    
    <script async src="//www.google-analytics.com/analytics.js"></script>
    <script async src="//rum-static.pingdom.net/pa-540f204eabe53d0d45ea5eb7.js"></script>
    

    <script defer src="/js/defer-start.min.js?v=AekJv8UoXfZb85z2wpEcIdHXJ_NDsE5ZHa3oFNS52kQ"></script>

    
    <script defer src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
    

    <script defer src="/js/video.min.js?v=t-dpexY-zVSox43wJXQJ9bZJ3C_z077SBQAJv1o0FBU"></script>

    

    <script defer src="/js/article.min.js?v=sMrOeKkUf1VlpAywK23j6-lyHnoi5fGCToJNx2NNtDQ"></script>


    <script defer src="//cdn.taboola.com/libtrc/givemesport/loader.js" id="tb_loader_script"></script>

    

    <script defer src="/js/defer-end.min.js?v=XlvPGjkz7Q5dkkMMw0S-dkfPa_0Oc_QuQwkZUlUzKWE"></script>

    <script defer src="//p.cpx.to/p/12298/px.js"></script>
    <script defer src="//connect.facebook.net/en_US/fbevents.js"></script>
    <script defer src="//sb.scorecardresearch.com/beacon.js"></script>
   <!--  <script defer src="//static.chartbeat.com/js/chartbeat.js"></script> --> 
   <script defer data-cfasync="false" id="parsely-cfg" data-parsely-site="givemesport.com" src="//cdn.parsely.com/keys/givemesport.com/p.js"></script>
    <script defer src="//certify-js.alexametrics.com/atrk.js"></script>
</head>
<body>
    <div class="gms-site">
        <div id="gms-message" class="gms-message"></div>
<header id="gms-site-header" class="gms-site-header">
    <div class="gms-max">
        <a href="/" class="gms-logo">GiveMeSport</a>
        <form action="/search" method="get" class="gms-search-form" id="gms-search-form">
    <input type="text" aria-label="Search GiveMeSport" placeholder="Search GiveMeSport" name="query" id="gms-search-text" class="gms-search-text">
</form>
    </div>
    <nav class="gms-menu-main" id="gms-menu-main" itemscope itemtype="http://schema.org/SiteNavigationElement">
    <div class="gms-max">
        <ul class="gms-inline-nav">
                <li><a href="/" itemprop="url" class="">Home</a></li>
                <li><a href="/football" itemprop="url" class="">Football</a></li>
                <li><a href="/boxing" itemprop="url" class="">Boxing</a></li>
                <li><a href="/wwe" itemprop="url" class="">WWE</a></li>
                <li><a href="/fantasy" itemprop="url" class="">Fantasy</a></li>
                <li><a href="/ufc" itemprop="url" class="">UFC</a></li>
                <li><a href="/gaming" itemprop="url" class="">Gaming</a></li>
                <li><a href="/formula-1" itemprop="url" class="">Formula 1</a></li>
                <li><a href="/athletics" itemprop="url" class="">Athletics</a></li>
                <li><a href="/womens-sport" itemprop="url" class="">GMSWomen</a></li>
                <li><a href="/fan-awards" itemprop="url" class="">Fan Awards</a></li>
            <li class="gms-menu-ctrl"><span>All sports</span></li>
        </ul>
    </div>
    <div class="gms-menu-all">
        <div class="gms-max">
            <ul>
                    <li><a href="/nba" itemprop="url">NBA</a></li>
                    <li><a href="/nfl" itemprop="url">NFL</a></li>
                    <li><a href="/cricket" itemprop="url">Cricket</a></li>
                    <li><a href="/mlb" itemprop="url">MLB</a></li>
                    <li><a href="/golf" itemprop="url">Golf</a></li>
                    <li><a href="/tennis" itemprop="url">Tennis</a></li>
                    <li><a href="/snooker" itemprop="url">Snooker</a></li>
                    <li><a href="/mls" itemprop="url">MLS</a></li>
                    <li><a href="/winter-sports" itemprop="url">Winter Sports</a></li>
                    <li><a href="/rugby-union" itemprop="url">Rugby</a></li>
                    <li><a href="/olympics" itemprop="url">Olympics</a></li>
            </ul>
        </div>
    </div>
</nav>

</header>
        <div class="gms-body gms-max">
            
            <div class="gms-ad gms-billboard" id="gms-ad-123826447-5"></div>
        <script>(function(a){a({dfp:"111_GiveMeSport_Landscape_Editorial_Top",id:"gms-ad-123826447-5",sizes:[[970,250],[728,90]]});}(this.gms.advert));</script>


            <link rel="preload" href="https://widgets.snack-projects.co.uk/gms/quizstyle.min.css?v=2020052901" as="style" onload="this.onload = null; this.rel = 'stylesheet';">
<noscript><link rel="stylesheet" href="https://widgets.snack-projects.co.uk/gms/quizstyle.min.css?v=2020052901"></noscript>


<main class="gms-main gms-cols-f-f">
    <div class="gms-col-fluid">
        <header class="gms-section-head gms-collapsible-head" itemscope itemtype="http://schema.org/SiteNavigationElement">
    <strong class="gms-section-title"><a href="/football" itemprop="url">Football</a></strong>
        <span class="gms-collapsible-ctrl"></span>
        <nav class="gms-section-nav">
            <ul class="gms-inline-nav">
                    <li><a href="/football/latest-news" itemprop="url" class="">News</a></li>
                    <li><a href="/football/fixtures" itemprop="url" class="">Results &amp; Fixtures</a></li>
                    <li><a href="/football/table" itemprop="url" class="">Tables</a></li>
                    <li><a href="/football/video-gallery" itemprop="url" class="">Video</a></li>
                    <li><a href="/football/directory" itemprop="url" class="">Popular Pages</a></li>
                    <li><a href="/football/quizzes" itemprop="url" class="">Quizzes</a></li>
            </ul>
        </nav>
</header>

        

        <article>
            <header class="gms-content-area gms-content-head">
                <h1 class="gms-content-headline">Fantasy Football: Three cheap FPL options who play twice in GW25</h1>
                <ul class="gms-content-details">
                        <li class="gms-author-avatar" ><img src="https://site-cdn.givemesport.com/content/img/gms-default-avatar.png" alt="Joe Willis" /></li>
    <li class="gms-content-author">By <a href="/joe-willis" rel="author" title="Joe Willis">Joe Willis</a></li>

                    <li class="gms-content-date"><time datetime="2021-02-19 09:03:36Z">09:03 19/02/21  BST</time></li>
                </ul>
                <ul class="gms-share">
    <li>
        <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25" class="gms-facebook" rel="nofollow noreferrer noopener" target="_blank">share on Facebook</a>
    </li>
    <li>
        <a href="https://twitter.com/share?url=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25&amp;amp;text=Fantasy%20Football:%20Three%20cheap%20FPL%20options%20who%20play%20twice%20in%20GW25" class="gms-twitter" rel="nofollow noreferrer noopener" target="_blank">share on Twitter</a>
    </li>
    <li data-platform="web">
        <a href="https://web.whatsapp.com/send?text=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25" class="gms-whatsapp" rel="nofollow noreferrer noopener" target="_blank">share on WhatsApp</a>
    </li>
    <li data-platform="mobile">
        <a href="whatsapp://send?text=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25" class="gms-whatsapp" rel="nofollow noreferrer noopener" target="_blank">share on WhatsApp</a>
    </li>
    <li>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25&amp;title=Fantasy%20Football:%20Three%20cheap%20FPL%20options%20who%20play%20twice%20in%20GW25" class="gms-linkedin" rel="nofollow noreferrer noopener" target="_blank">share on Linkedin</a>
    </li>
    <li>
        <a href="https://share.flipboard.com/bookmarklet/popout?v=2&amp;url=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25&amp;title=Fantasy%20Football:%20Three%20cheap%20FPL%20options%20who%20play%20twice%20in%20GW25" class="gms-flipboard" rel="nofollow noreferrer noopener" target="_blank">share on Flipboard</a>
    </li>
    <li data-platform="mobile">
        <a href="fb-messenger://share/?link=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25&amp;app_id=112285998808712" class="gms-messenger" rel="nofollow noreferrer noopener">share on Messenger</a>
    </li>
    <li>
        <a href="mailto:?body=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25&amp;amp;subject=Fantasy%20Football:%20Three%20cheap%20FPL%20options%20who%20play%20twice%20in%20GW25" class="gms-email" rel="nofollow noreferrer noopener">share on Email</a>
    </li>
</ul>
            </header>
            <picture class="gms-content-media">
        <source media="(min-width: 651px)" srcset="https://site-cdn.givemesport.com/images/21/02/19/2afb5e17e842515d35e47aff7420a86a/960.jpg">
        
        
        
        
        <source media="(min-width: 420px)" srcset="https://site-cdn.givemesport.com/images/21/02/19/2afb5e17e842515d35e47aff7420a86a/650.jpg">
        
        
        
        
        <source media="(min-width: 321px)" srcset="https://site-cdn.givemesport.com/images/21/02/19/2afb5e17e842515d35e47aff7420a86a/419.jpg">
        
        
        
        
        <source media="(max-width: 320px)" srcset="https://site-cdn.givemesport.com/images/21/02/19/2afb5e17e842515d35e47aff7420a86a/320.jpg">
        
        
        
        
        
        
        
        
    <img src="https://site-cdn.givemesport.com/images/21/02/19/2afb5e17e842515d35e47aff7420a86a/320.jpg" alt="Raphinha" width="320" height="207">
</picture>




            <div class="gms-content-wrapper gms-content-area gms-content-body gms-content-intro">

                <p><strong>After four teams played a double game week in GW24, we have another double-header for two more Premier League teams in GW25, as&nbsp;<a href="https://www.premierleague.com/fixtures" target="_blank" rel="nofollow">Leeds United and Southampton</a>&nbsp;both play twice in five days.</strong></p>
<p>Leeds play Wolves on Friday night and Southampton host Chelsea on Saturday before they play each other on Tuesday evening. This leaves lots of room for large FPL points hauls this week.&nbsp;</p><div class="gms-ad gms-ad-lazy gms-outstream" id="gms-ad-123825532-1" data-dfp="199_Desktop_Outstream_Video" data-sizes="[[648,480],[300,250]]"></div>
<p>With the majority of FPL managers opting to select the popular Patrick Bamford (&pound;6.8m) or Danny Ings (&pound;8.4m), we take a look at some cheap, differential alternatives who will play twice in GW25...</p>
<script>
    (function (g, v) {
        g[v] = g[v] || {};
        g[v].config = g[v].config || {};
        g[v].config["player_637493239272242188"] = {
            loc: "AEV",
            playlist: [{"Id":0,"Position":0,"Title":"The Highest Rated FIFA XI Of All-Time 🎮🔥 ","File":"https://site-cdn.givemesport.com/video/21/02/01/cms/ae62a31878b74713a667bb403134b97d/flash/hq/1024x576/ae62a31878b74713a667bb403134b97d.mp4","Image":"https://site-cdn.givemesport.com/images/21/02/01/a82559a40453d671e41806f4dfcc5ecc/960.jpg","Width":0,"Height":0},{"Id":0,"Position":0,"Title":"6 Times Chelsea Proved They're The World's Most Ruthless Club","File":"https://site-cdn.givemesport.com/video/21/02/01/cms/adce9a9dad354e7f9a25238177a2afb0/flash/hq/1024x576/adce9a9dad354e7f9a25238177a2afb0.mp4","Image":"https://site-cdn.givemesport.com/images/21/02/01/b9e69d5d6f2896f2bdb8d07cffcd2fb3/960.jpg","Width":0,"Height":0},{"Id":0,"Position":0,"Title":"Fabrizio Romano interview","File":"https://site-cdn.givemesport.com/video/21/01/08/cms/7136b710616b485496ffe2ae4dbc3da6/flash/mq/640x360/7136b710616b485496ffe2ae4dbc3da6.mp4","Image":"https://site-cdn.givemesport.com/images/21/01/08/15c97e400a1d8ac889f4ca522f2ef884/960.jpg","Width":0,"Height":0},{"Id":0,"Position":0,"Title":"Callux takes on Adebayo Akinfenwa & Harry Pinero in 'Park the Bus Challenge'","File":"https://site-cdn.givemesport.com/video/20/12/17/cms/07ba5a313e1842e6af121d950f1989b7/flash/mq/640x360/07ba5a313e1842e6af121d950f1989b7.mp4","Image":"https://site-cdn.givemesport.com/images/20/12/17/95f75af4db16bf919baaa5bfaa012504/960.jpg","Width":0,"Height":0}]
        };
    }(this.gms, "video"));
</script>
<div class="gms-video-container">
    <div class="gms-video-screen">
        <video id="player_637493239272242188" class="gms-video-player" playsinline="" muted="" autoplay=""></video>
    </div>
</div>
<p><strong>Raphinha - Leeds United (&pound;5.3m)</strong></p>
<p>Leeds winger Raphinha has been in brilliant form over the last few game weeks, helping his team with both assists and goals himself. He <a href="https://www.premierleague.com/players/24156/Raphinha/overview" target="_blank" rel="nofollow">has six goal contributions in his last five matches,</a> scoring twice and assisting four times.&nbsp;</p>
<p>From an FPL perspective, he has recorded 38 FPL points over these past five game weeks. Raphinha is also <a href="https://www.whoscored.com/Teams/19/Show/England-Leeds" target="_blank" rel="nofollow">second for Leeds in shots per game and second for key passes per game,</a> highlighting his impact on the side. Surprisingly, he is also only owned by just 4% of FPL managers.&nbsp;</p>
<p>Leeds face a Wolves side (A) that have only won four games in their last 14 matches, and have <a href="https://www.premierleague.com/stats/top/clubs/clean_sheet?se=363" target="_blank" rel="nofollow">struggled to keep clean sheets this season (6).</a> Despite their win over Southampton last weekend, this could be a great opportunity for Raphinha&nbsp;to get another goal contribution.&nbsp;&nbsp;</p>
<p>They then face a Southampton side (H) that&nbsp;<a href="https://www.skysports.com/southampton-results" target="_blank" rel="nofollow">have lost their last six league matches</a>&nbsp;and have conceded 14 goals in their last three games. With Bamford flying as well, Leeds and Raphinha are could reward shrewd FPL managers in GW25.</p>
<p><strong>Stuart Dallas - Leeds United (&pound;4.8m)</strong></p>
    <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 481px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/19/9f430caa117692c1913d12822fc5b0b7/690.jpg">
            
            
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 480px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/19/9f430caa117692c1913d12822fc5b0b7/480.jpg">
            
            
        <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/19/9f430caa117692c1913d12822fc5b0b7/690.jpg" alt="Dallas" width="690" height="460">
    </picture>

<p>Many may think that having a Leeds defender in their FPL team is a dangerous move. They have <a href="https://www.premierleague.com/stats/top/clubs/goals_conceded" target="_blank" rel="nofollow">conceded the second most goals</a> this season (42), only behind a defensively woeful and relegation-threatened West Brom team.&nbsp;</p>
<p>However, despite being listed as a defender on FPL, Stuart Dallas has been operating in a central midfield role for Leeds this season. This means that he promises more opportunities for goal contributions compared to other defenders.</p>
<p>The &pound;4.9m man already <a href="https://www.premierleague.com/players/8148/Stuart-Dallas/overview" target="_blank" rel="nofollow">has four goals and three assists this season,</a> including two-goal contributions and a clean sheet in his last four matches.</p>
<p>Wolves and Southampton are two sides that have also struggled for goals in recent weeks. This makes Dallas a worthwhile investment, as he could provide good returns defensively and, more importantly, offensively to give your FPL team lots of points.&nbsp;</p>
<p><strong>James Ward-Prowse - Southampton (&pound;</strong><strong>6.0m)</strong></p>
    <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 481px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/19/d91f0fbfdb1b01a5cc0ce5dc8e832b38/690.jpg">
            
            
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 480px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/19/d91f0fbfdb1b01a5cc0ce5dc8e832b38/480.jpg">
            
            
        <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/19/d91f0fbfdb1b01a5cc0ce5dc8e832b38/690.jpg" alt="JWP" width="690" height="444">
    </picture>

<p>Our final cheap alternative for GW25 is Southampton's midfield maestro, James Ward-Prowse. The &pound;6.0m FPL man has scored five goals, <a href="https://www.skysports.com/football/newcastle-united-vs-southampton/429063" target="_blank" rel="nofollow">including one against Newcastle</a> two weeks ago, and produced five assists already this season - totaling 100 FPL points so far.&nbsp;</p>
<p>Despite their poor run of form in recent weeks, Ward-Prowse has offered the Saints a glimmer of light with his performances this term. He leads the teams <a href="https://www.whoscored.com/Teams/18/Show/England-Southampton" target="_blank" rel="nofollow">in assists and key passes so far</a> and has been deadly from dead ball situations.</p>
<p>In GW25 they face a tough Chelsea side first, who are unbeaten since new manager Thomas Tuchel took charge.&nbsp;However, after&nbsp;<a href="https://www.skysports.com/football/manchester-united-vs-southampton/429051" target="_blank" rel="nofollow">their 9-0 humiliation at the hands of Man United,</a> Southampton's performances have been improving and they will want to prevent that type of embarrassment from happening again.&nbsp;</p>
<p>Ward-Prowse then travels to Leeds, who have the <a href="https://www.premierleague.com/stats/top/clubs/goals_conceded" target="_blank" rel="nofollow">second-worst defensive record in the league</a> and have kept only one clean sheet in their last eight matches. Therefore, this could definitely be a great double game week for them to get back on track - with Ward-Prowse in the middle of all the action.</p>
                <ul class="gms-content-tags" itemscope itemtype="http://schema.org/SiteNavigationElement">
        <li><a href="/fantasy" itemprop="url">Fantasy</a></li>
        <li><a href="/football" itemprop="url">Football</a></li>
        <li><a href="/james-ward-prowse" itemprop="url">James Ward-Prowse</a></li>
        <li><a href="/premier-league" itemprop="url">Premier League</a></li>
        <li><a href="/raphinha-dias-belloli" itemprop="url">Raphinha Dias Belloli</a></li>
        <li><a href="/stuart-dallas" itemprop="url">Stuart Dallas</a></li>
</ul>

                <nav class="gms-circulation">
    <a href="/1651808-harry-kane-mooted-with-mauricio-pochettino-reunion-at-paris-saintgermain?utm_source=navigation-next&amp;utm_medium=internal" class="gms-next">next story</a>
    <a href="/1651820-messi-ronaldo-mbappe-which-player-has-the-best-defensive-statistics?utm_source=navigation-previous&amp;utm_medium=internal" class="gms-prev">previous story</a>
</nav>
                    <div style="margin-top: 1rem;"></div>
                    <script id="fan-awards" type="text/javascript" src="https://fan-awards.snack-projects.co.uk/widget/embed-scheduled.js" defer></script>
                <a href="https://www.newsnow.co.uk/h/Sport" title="Click here for more Sport news from NewsNow" rel="nofollow noopener" target="_blank" class="gms-newsnow">
                    <span>News Now - Sport News</span>
                </a>
            </div>

<aside class="gms-group gms-related-list">
    <h2 class="gms-group-head">Related articles</h2>
        <div class="gms-teaser">
            <a href="/1647055-fantasy-football-the-best-january-signings-that-could-benefit-your-fpl-team?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories" title="Fantasy Football: The best January signings that could give your FPL team a lift" class="gms-teaser-image">
                
                <picture class="gms-lazy-image">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/06/04f71e1f47850ab23f4fb13383182958/419.jpg">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/06/04f71e1f47850ab23f4fb13383182958/144.jpg">
                    <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/06/04f71e1f47850ab23f4fb13383182958/320.jpg" alt="FPL Jan Signings" width="480" height="310">
                </picture>
            </a>
            <div class="gms-teaser-content">
                <h3 class="gms-teaser-title"><a href="/1647055-fantasy-football-the-best-january-signings-that-could-benefit-your-fpl-team?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories">Fantasy Football: The best January signings that could give your FPL team a lift</a></h3>
            </div>
        </div>
        <div class="gms-teaser">
            <a href="/1651731-fantasy-football-the-top-five-fpl-captain-picks-for-gw25?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories" title="Fantasy Football: Top five captain picks ahead of GW25" class="gms-teaser-image">
                
                <picture class="gms-lazy-image">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/83caf3532ace709f9336a28ce186bf40/419.jpg">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/83caf3532ace709f9336a28ce186bf40/144.jpg">
                    <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/18/83caf3532ace709f9336a28ce186bf40/320.jpg" alt="GW25 Captains" width="480" height="310">
                </picture>
            </a>
            <div class="gms-teaser-content">
                <h3 class="gms-teaser-title"><a href="/1651731-fantasy-football-the-top-five-fpl-captain-picks-for-gw25?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories">Fantasy Football: Top five captain picks ahead of GW25</a></h3>
            </div>
        </div>
        <div class="gms-teaser">
            <a href="/1651753-fantasy-football-time-to-bring-timo-werner-back-into-your-fpl-team?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories" title="Fantasy Football: Are we about to start seeing the best of Werner?" class="gms-teaser-image">
                
                <picture class="gms-lazy-image">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/e686afbb4891250c5dd556350ed61f79/419.jpg">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/e686afbb4891250c5dd556350ed61f79/144.jpg">
                    <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/18/e686afbb4891250c5dd556350ed61f79/320.jpg" alt="GW25 Werner" width="480" height="310">
                </picture>
            </a>
            <div class="gms-teaser-content">
                <h3 class="gms-teaser-title"><a href="/1651753-fantasy-football-time-to-bring-timo-werner-back-into-your-fpl-team?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories">Fantasy Football: Are we about to start seeing the best of Werner?</a></h3>
            </div>
        </div>
</aside>
        <footer class="gms-content-area gms-content-foot">
            <ul class="gms-share">
    <li>
        <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25" class="gms-facebook" rel="nofollow noreferrer noopener" target="_blank">share on Facebook</a>
    </li>
    <li>
        <a href="https://twitter.com/share?url=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25&amp;amp;text=Fantasy%20Football:%20Three%20cheap%20FPL%20options%20who%20play%20twice%20in%20GW25" class="gms-twitter" rel="nofollow noreferrer noopener" target="_blank">share on Twitter</a>
    </li>
    <li data-platform="web">
        <a href="https://web.whatsapp.com/send?text=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25" class="gms-whatsapp" rel="nofollow noreferrer noopener" target="_blank">share on WhatsApp</a>
    </li>
    <li data-platform="mobile">
        <a href="whatsapp://send?text=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25" class="gms-whatsapp" rel="nofollow noreferrer noopener" target="_blank">share on WhatsApp</a>
    </li>
    <li>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25&amp;title=Fantasy%20Football:%20Three%20cheap%20FPL%20options%20who%20play%20twice%20in%20GW25" class="gms-linkedin" rel="nofollow noreferrer noopener" target="_blank">share on Linkedin</a>
    </li>
    <li>
        <a href="https://share.flipboard.com/bookmarklet/popout?v=2&amp;url=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25&amp;title=Fantasy%20Football:%20Three%20cheap%20FPL%20options%20who%20play%20twice%20in%20GW25" class="gms-flipboard" rel="nofollow noreferrer noopener" target="_blank">share on Flipboard</a>
    </li>
    <li data-platform="mobile">
        <a href="fb-messenger://share/?link=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25&amp;app_id=112285998808712" class="gms-messenger" rel="nofollow noreferrer noopener">share on Messenger</a>
    </li>
    <li>
        <a href="mailto:?body=https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25&amp;amp;subject=Fantasy%20Football:%20Three%20cheap%20FPL%20options%20who%20play%20twice%20in%20GW25" class="gms-email" rel="nofollow noreferrer noopener">share on Email</a>
    </li>
</ul>
            
        </footer>
        </article>
        <div id="taboola-below-article-thumbnails-1" class="gms-syndication"></div>
    </div>
    <aside class="gms-col-fixed">
        
        <section class="gms-group gms-group-accent">
    <h2 class="gms-group-head">Trending Football Stories</h2>
    <ol class="gms-trending">
            <li><a href="/1651783-wilfried-zaha-crystal-palace-star-becomes-first-premier-league-star-to-say-he-wont-take-the-knee">Wilfried Zaha: Crystal Palace star becomes first Premier League star to say he won&#x27;t take the knee</a></li>
            <li><a href="/1651807-ronaldo-messi-wengers-verdict-on-juventus-and-barca-stars-teammates">Ronaldo &amp; Messi: Wenger&#x27;s verdict on Juventus and Barca stars&#x2019; teammates</a></li>
    </ol>
</section>
        
                <div class="gms-ad gms-ad-lazy gms-mpu" id="gms-ad-123826449-6" data-dfp="112_GiveMeSport_Portrait_Editorial_Right" data-sizes="[[300,600],[300,250]]"></div>

        
        <section class="gms-group">
            <h2 class="gms-group-head"><a href="/football/latest-news">Latest Football articles</a></h2>
<div class="gms-teaser">
    <a href="/1651820-messi-ronaldo-mbappe-which-player-has-the-best-defensive-statistics" title="Messi, Ronaldo, Mbappe: Which player has the best defensive statistics? " class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/19/8dc678de11e0795a057804369c03326c/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/19/8dc678de11e0795a057804369c03326c/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/19/8dc678de11e0795a057804369c03326c/320.jpg" alt="Lionel Messi" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1651820-messi-ronaldo-mbappe-which-player-has-the-best-defensive-statistics">Messi, Ronaldo, Mbappe: Which player has the best defensive statistics? </a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            <li class="gms-content-date"><time datetime="2021-02-19T09:29:03">3 minutes ago</time></li>
        </ul>
    </div>
</div><div class="gms-teaser">
    <a href="/1651807-ronaldo-messi-wengers-verdict-on-juventus-and-barca-stars-teammates" title="Ronaldo &amp; Messi: Wenger&#x27;s verdict on Juventus and Barca stars&#x2019; teammates" class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/19/c8ab27adc5598a3de2609c6bcb071f32/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/19/c8ab27adc5598a3de2609c6bcb071f32/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/19/c8ab27adc5598a3de2609c6bcb071f32/320.jpg" alt="Arsene Wenger claims Cristiano Ronaldo and Lionel Messi both need better teammates" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1651807-ronaldo-messi-wengers-verdict-on-juventus-and-barca-stars-teammates">Ronaldo &amp; Messi: Wenger&#x27;s verdict on Juventus and Barca stars&#x2019; teammates</a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            <li class="gms-content-date"><time datetime="2021-02-19T08:17:57">an hour ago</time></li>
        </ul>
    </div>
</div><div class="gms-teaser">
    <a href="/1651797-big-update-on-cavanis-man-utd-future-ahead-of-summer-transfer-window" title="Big update on Cavani&#x27;s Man Utd future ahead of summer transfer window" class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/44b4e754f902521f67e9b1337f1cefbe/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/44b4e754f902521f67e9b1337f1cefbe/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/18/44b4e754f902521f67e9b1337f1cefbe/320.jpg" alt="Cavani" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1651797-big-update-on-cavanis-man-utd-future-ahead-of-summer-transfer-window">Big update on Cavani&#x27;s Man Utd future ahead of summer transfer window</a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            <li class="gms-content-date"><time datetime="2021-02-19T08:00:00">an hour ago</time></li>
        </ul>
    </div>
</div><div class="gms-teaser">
    <a href="/1651766-man-utd-set-to-enter-bidding-for-astonishing-99mrated-star-this-summer" title="Man Utd set to enter bidding for astonishing &#xA3;99m-rated star this summer " class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/2f1553303a9141edc879491bd1d9048e/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/2f1553303a9141edc879491bd1d9048e/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/18/2f1553303a9141edc879491bd1d9048e/320.jpg" alt="Solskjaer" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1651766-man-utd-set-to-enter-bidding-for-astonishing-99mrated-star-this-summer">Man Utd set to enter bidding for astonishing &#xA3;99m-rated star this summer </a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            <li class="gms-content-date"><time datetime="2021-02-18T10:50:00">10 hours ago</time></li>
        </ul>
    </div>
</div><div class="gms-teaser">
    <a href="/1651765-it-will-be-difficult-pundit-claims-spurs-face-battle-to-land-108mrated-pl-star" title="&quot;It will be difficult&quot; - Pundit claims Spurs face battle to land &#xA3;10.8m-rated PL star" class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/415e930311a9fde47ec1d47c298a9834/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/415e930311a9fde47ec1d47c298a9834/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/18/415e930311a9fde47ec1d47c298a9834/320.jpg" alt="Mourinho" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1651765-it-will-be-difficult-pundit-claims-spurs-face-battle-to-land-108mrated-pl-star">&quot;It will be difficult&quot; - Pundit claims Spurs face battle to land &#xA3;10.8m-rated PL star</a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            <li class="gms-content-date"><time datetime="2021-02-18T10:35:00">10 hours ago</time></li>
        </ul>
    </div>
</div><div class="gms-teaser">
    <a href="/1651763-would-score-40-to-50-goals-kane-backed-to-make-huge-switch-away-from-spurs" title="&quot;Would score 40 to 50 goals&quot; - Kane backed to make huge switch away from Spurs" class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/db1c2a5c7cbce84203ed703f525c9c15/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/21/02/18/db1c2a5c7cbce84203ed703f525c9c15/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/21/02/18/db1c2a5c7cbce84203ed703f525c9c15/320.jpg" alt="Kane" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1651763-would-score-40-to-50-goals-kane-backed-to-make-huge-switch-away-from-spurs">&quot;Would score 40 to 50 goals&quot; - Kane backed to make huge switch away from Spurs</a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            <li class="gms-content-date"><time datetime="2021-02-18T09:15:00">12 hours ago</time></li>
        </ul>
    </div>
</div>            <footer class="gms-group-foot">
                <a href="/football/latest-news">More Football news</a>
            </footer>
        </section>
                <div class="gms-ad gms-ad-lazy gms-mpu" id="gms-ad-123826451-7" data-dfp="113_GiveMeSport_Portrait_Editorial_Right" data-sizes="[[300,600],[300,250]]"></div>

    </aside>
</main>
        </div>
        <footer class="gms-site-footer">
    <div class="gms-max">
        <a href="/" class="gms-logo">GiveMeSport</a>
        <ul class="gms-site-footer-nav" itemscope itemtype="http://schema.org/SiteNavigationElement">
            <li><a href="/about" itemprop="url">About</a></li>
            <li><a href="/our-writers" itemprop="url">Our Writers</a></li>
            <li><a href="/privacy-policy" itemprop="url">Privacy</a></li>
            <li><a href="/legal" itemprop="url">Legal</a></li>
            <li><a href="/accessibility" itemprop="url">Accessibility</a></li>
            <li><a href="/cookies-policy" itemprop="url">Cookies</a></li>
            <li><a href="/terms-and-conditions" itemprop="url">Terms</a></li>
            <li><a href="/sponsored-content" itemprop="url">Sponsored</a></li>
            <li><a href="/academy" itemprop="url">Academy</a></li>
            <li><a href="/contact-us" itemprop="url">Contact</a></li>
        </ul>
        <ul class="gms-social-links">
    <li><a href="https://www.facebook.com/GiveMeSport" target="_blank" rel="noopener" class="gms-facebook" title="Follow us on Facebook">Facebook</a></li>
    <li><a href="https://twitter.com/GiveMeSport" target="_blank" rel="noopener" class="gms-twitter" title="Follow us on Twitter">Twitter</a></li>
    <li><a href="https://www.youtube.com/user/GiveMeSport" target="_blank" rel="noopener" class="gms-youtube" title="Follow us on YouTube">YouTube</a></li>
    <li><a href="https://www.instagram.com/givemesport" target="_blank" rel="noopener" class="gms-instagram" title="Follow us on Instagram">Instagram</a></li>
</ul>
        <p class="gms-site-copyright">&copy; 2021 Sports New Media Limited. All Rights Reserved.</p>
    </div>
</footer>
    </div>
            <div class="gms-ad gms-interstitial" id="gms-ad-123826415-2"></div>
        <script>(function(a){a({dfp:"100_GiveMeSport_Out-of-page",id:"gms-ad-123826415-2",sizes:[]});}(this.gms.advert));</script>

    
        <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25"
    },
    "headline": "Fantasy Football: Three cheap FPL options who play twice in GW25",
    "datePublished": "2021-02-19T09:03:36.4440000Z",
    "dateModified": "2021-02-19T09:03:36.4440000Z",
    "description": "Fantasy Football: Three cheap FPL options who play twice in GW25",
    "author": {
        "@type": "Person",
        "name": "Joe Willis",
        "sameAs": "https://www.givemesport.com/joe-willis"
    },
    "publisher": {
        "@type": "Organization",
        "url": "https://www.givemesport.com",
        "name": "GiveMeSport",
        "logo": {
            "@type": "ImageObject",
            "url": "https://site-cdn.givemesport.com/v4/images/logo-gms-black.png"
        }
    },
    "thumbnailUrl": "https://site-cdn.givemesport.com/images/21/02/19/2afb5e17e842515d35e47aff7420a86a/144.jpg",
    "creator": ["Joe Willis"],
    "keywords": ["Fantasy","Football","James Ward-Prowse","Premier League","Raphinha Dias Belloli","Stuart Dallas"],
    "articleSection": "Football",
    "url": "https://www.givemesport.com/1651815-fantasy-football-three-cheap-fpl-options-who-play-twice-in-gw25",
    "image": ["https://site-cdn.givemesport.com/images/21/02/19/f5557248278c103e0979d18519c59a58/1216.jpg","https://site-cdn.givemesport.com/images/21/02/19/f5557248278c103e0979d18519c59a58/1204.jpg","https://site-cdn.givemesport.com/images/21/02/19/f5557248278c103e0979d18519c59a58/1201.jpg"]    }
</script>

    <noscript class="gms-no-script">
        <img src="//www.facebook.com/tr?id=1762069164047152&ev=PageView&noscript=1" height="1" width="1" alt="">
        <img src="//certify.alexametrics.com/atrk.gif?account=zRWAh1aAod00ah" height="1" width="1" alt="">
        <img src="//b.scorecardresearch.com/p?c1=2&amp;c2=&amp;c3=&amp;c4=&amp;c5=&amp;c6=&amp;c15=&amp;cv=2.0&amp;cj=1" height="1" width="1" alt="">
    </noscript>
</body>
</html>