<!DOCTYPE html>
<html lang="en-GB">
<head>
    <meta charset="utf-8" />
    <title>Jamie Carragher: Liverpool legend called YouTuber a &#x27;stupid little p***k&#x27; after brutal tackle | GiveMeSport</title>
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=5">
    <meta name="application-name" content="GiveMeSport">
    <meta name="theme-color" content="#000000">
    <meta name="msapplication-config" content="/msconfig.xml">
    <meta name="apple-mobile-web-app-title" content="GiveMeSport">
    <meta name="apple-mobile-web-app-capable" content="yes">
    <meta name="apple-mobile-web-app-status-bar-style" content="black">
            <meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1">
        <meta name="description" content="Liverpool legend Jamie Carragher took part in the 2016 EE Wembley Cup match alongside various YouTubers">
        <meta name="twitter:card" content="summary_large_image">
        <meta name="twitter:site" content="GiveMeSport">
        <meta name="twitter:creator" content="GiveMeSport">
        <meta name="keywords" content="football,quiz">
        <meta property="fb:pages" content="566760030037879">
        <meta property="fb:app_id" content="112285998808712">
        <meta property="og:site_name" content="GiveMeSport">
        <meta property="fb:admins" content="100000241027088">
        <meta property="og:type" content="article">
        <meta property="article:publisher" content="https://www.facebook.com/GiveMeSport/">
        <meta property="og:url" content="https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle">
        <meta property="og:title" content="Jamie Carragher called YouTuber a &#x27;stupid little p***k&#x27; after brutal tackle in 2016 charity match">
        <meta property="og:description" content="Jamie Carragher called YouTuber a &#x27;stupid little p***k&#x27; after brutal tackle in 2016 charity match">
        <meta property="article:published_time" content="2022-01-12T13:43:09.8950000Z">
        <meta property="article:modified_time" content="2022-01-12T13:43:09.8950000Z">
        <meta property="article:tag" content="football,quiz">
        <meta property="article:section" content="Football">
        <meta property="article:author" content="https://www.givemesport.com/danny-ryan">
        <meta property="og:image" content="https://site-cdn.givemesport.com/images/22/01/12/004c621ecf434c7288ec4af4f6e39893/1200.jpg">
        <meta property="og:image:width" content="1200">
        <meta property="og:image:height" content="630">
    <link rel="amphtml" href="https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle?amp" />

    <link rel="apple-touch-icon" sizes="60x60" href="https://site-cdn.givemesport.com/v4/icons/gms-60x60.png">
    <link rel="apple-touch-icon" sizes="76x76" href="https://site-cdn.givemesport.com/v4/icons/gms-76x76.png">
    <link rel="apple-touch-icon" sizes="120x120" href="https://site-cdn.givemesport.com/v4/icons/gms-120x120.png">
    <link rel="apple-touch-icon" sizes="152x152" href="https://site-cdn.givemesport.com/v4/icons/gms-152x152.png">
    <link rel="apple-touch-icon" sizes="167x167" href="https://site-cdn.givemesport.com/v4/icons/gms-167x167.png">
    <link rel="apple-touch-icon" sizes="180x180" href="https://site-cdn.givemesport.com/v4/icons/gms-180x180.png">
    <link rel="apple-touch-icon" sizes="512x512" href="https://site-cdn.givemesport.com/v4/icons/gms-512x512.png">
    <link rel="apple-touch-startup-image" sizes="2048x2732" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-2048x2732.png">
    <link rel="apple-touch-startup-image" sizes="1668x2224" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-1668x2224.png">
    <link rel="apple-touch-startup-image" sizes="1536x2048" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-1536x2048.png">
    <link rel="apple-touch-startup-image" sizes="1125x2436" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-1125x2436.png">
    <link rel="apple-touch-startup-image" sizes="1242x2208" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-1242x2208.png">
    <link rel="apple-touch-startup-image" sizes="750x1334" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-750x1334.png">
    <link rel="apple-touch-startup-image" sizes="640x1136" href="https://site-cdn.givemesport.com/v4/icons/gms-splash-640x1136.png">
    <link rel="icon" type="image/png" sizes="32x32" href="https://site-cdn.givemesport.com/v4/icons/favicon-48x48.png">
    <link rel="icon" type="image/png" sizes="32x32" href="https://site-cdn.givemesport.com/v4/icons/favicon-32x32.png">
    <link rel="icon" type="image/png" sizes="16x16" href="https://site-cdn.givemesport.com/v4/icons/favicon-16x16.png">
    <link rel="shortcut icon" href="/favicon.ico">
    <link rel="manifest" href="/manifest.json">
    <link rel="preconnect" href="https://site-cdn.givemesport.com" crossorigin>
    <link rel="preconnect" href="https://www.google-analytics.com" crossorigin>
    <link rel="preconnect" href="https://www.googletagservices.com" crossorigin>
    <link rel="preconnect" href="https://www.facebook.com" crossorigin>
    <link rel="canonical" href="https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle">
    <!--Version Number: 0.0.736-master -->
    
    

	<link href="https://fonts.googleapis.com/css2?family=DM+Sans:wght@400;700&display=swap" rel="stylesheet">
    <style>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</style>
    <link rel="preload" href="/css/article.min.css?v=YmvIOv_VICIhG6monRfFo7dsYGX__x4MhHs6HZDF5Es" as="style" onload="this.onload = null; this.rel = 'stylesheet';">
    <noscript><link rel="stylesheet" href="/css/article.min.css?v=YmvIOv_VICIhG6monRfFo7dsYGX__x4MhHs6HZDF5Es"></noscript>


    
    
        <link rel="preload" href="/css/common.min.css?v=9wLnLb_Hxm69--8ER5fqmK-kAar8XRtb-gdbYvBFsDA" as="style" onload="this.onload=null;this.rel='stylesheet'">
        <noscript><link rel="stylesheet" href="/css/common.min.css?v=9wLnLb_Hxm69--8ER5fqmK-kAar8XRtb-gdbYvBFsDA"></noscript>
        <script>(function (w) { w.gms = { config: { enviro: "live" } }; }(this));</script>
    
    
    <script>
        (function (c) {
            c.author = "Danny Ryan";
            c.authortype = ""; //TODO: Need on model
            c.channel = "Football";
            c.id = 1818620;
            c.pagetype = "editorial";
            c.sponsor = "";
            c.tag = ["Football","Quiz"];
            c.team = "";
            c.newsNowTitle = "Jamie Carragher's three words to YouTuber after brutal tackle in 2016 charity match [video]";
            c.pubTime = "13-14";
            c.pubDate = "20220112";
            c.viewType = "Thumbnail";
        }(this.gms.config));
    </script>

    
    
        <script>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</script>
    

    <script async src="//js-sec.indexww.com/ht/p/190445-133507786892336.js"></script>
    <script>
        (function() {
            __tcfapi('addEventListener', 2, function(tcData,success){

                if(success){
                    if(tcData.eventStatus === 'tcloaded' || tcData.eventStatus === 'useractioncomplete') {

                        if(tcData.gdprApplies){
                            if(tcData.tcString){
                                console.log('SUCCESS!');
                                console.log(tcData);

                                var el = document.createElement('script');
                                var fs = document.getElementsByTagName('script')[0];
                                var url = '//www.googletagservices.com/tag/js/gpt.js';

                                el.async = true;
                                el.type = 'text/javascript';
                                el.src = url;

                                fs.parentNode.insertBefore(el, fs);
                            }
                        } else {
                            //gdpr doesnt apply
                            var el = document.createElement('script');
                            var fs = document.getElementsByTagName('script')[0];
                            var url = '//www.googletagservices.com/tag/js/gpt.js';

                            el.async = true;
                            el.type = 'text/javascript';
                            el.src = url;

                            fs.parentNode.insertBefore(el, fs);
                        }
                    }
                }    
            });
        })();
    </script>

    
    <script async src="//www.google-analytics.com/analytics.js"></script>
    <script async src="//rum-static.pingdom.net/pa-540f204eabe53d0d45ea5eb7.js"></script>
    

    <script defer src="/js/defer-start.min.js?v=d3Oz8Ss0uV7AOPEgj5vYJX4GTc6hcjtwiq6k45jKAXQ"></script>

    
    <script defer src="//imasdk.googleapis.com/js/sdkloader/ima3.js"></script>
    <script defer src="/js/prebid-video.js"></script>
    <script>var pbjs = pbjs || {}; pbjs.que = pbjs.que || [];</script>
    

    <script defer src="/js/video.min.js?v=PejEzFxg_wr0CPexYNhUfdda9d_NIFdSZSqnDT_-9kw"></script>

    

    <script defer src="/js/article.min.js?v=uoxI0vbtNq1dFPEQHgZ8CrmZQEl72EEoZlEiZjZrGts"></script>



    <script defer src="/js/quiz.min.js?v=Qf5JZ1O8epUwYbwXYrYEaG5pIYUQZLN8EbG4ZoWD6Ew"></script>

        <script defer src="//cdn.taboola.com/libtrc/snackmedianew-givemesport/loader.js" id="tb_loader_script"></script>

    

    <script defer src="/js/defer-end.min.js?v=KSyT7b3NTbvlYfWHj4bQjy6T5PV2F2C_fihfySaSR7Q"></script>

    <!-- <script defer src="//p.cpx.to/p/12298/px.js"></script> -->
    <script defer src="//connect.facebook.net/en_US/fbevents.js"></script>
    <script defer src="//sb.scorecardresearch.com/beacon.js"></script>
   <!--  <script defer src="//static.chartbeat.com/js/chartbeat.js"></script> --> 
   <script defer data-cfasync="false" id="parsely-cfg" data-parsely-site="givemesport.com" src="//cdn.parsely.com/keys/givemesport.com/p.js"></script>
    <script defer src="//certify-js.alexametrics.com/atrk.js"></script>
</head>
<body>
    <div class="gms-site">
        <div id="gms-message" class="gms-message"></div>
<header id="gms-site-header" class="gms-site-header">
    <div class="gms-max">
        <a href="/" class="gms-logo gms-logo-default">GiveMeSport</a>
        <form action="/search" method="get" class="gms-search-form" id="gms-search-form">
    <input type="text" aria-label="Search GiveMeSport" placeholder="Search GiveMeSport" name="query" id="gms-search-text" class="gms-search-text">
</form>
    </div>
    <nav class="gms-menu-main" id="gms-menu-main" itemscope itemtype="http://schema.org/SiteNavigationElement">
    <div class="gms-max">
        <ul class="gms-inline-nav">
                <li><a href="/football" itemprop="url" class="">Football</a></li>
                <li><a href="/boxing" itemprop="url" class="">Boxing</a></li>
                <li><a href="/wwe" itemprop="url" class="">WWE</a></li>
                <li><a href="/ufc" itemprop="url" class="">UFC</a></li>
                <li><a href="/gaming" itemprop="url" class="">Gaming</a></li>
                <li><a href="/tennis" itemprop="url" class="">Tennis</a></li>
                <li><a href="/formula-1" itemprop="url" class="">Formula 1</a></li>
            <li class="gms-menu-ctrl"><span>All sports</span></li>
        </ul>
    </div>
    <div class="gms-menu-all">
        <div class="gms-max">
            <ul>
                    <li><a href="/wrestling" itemprop="url">Wrestling</a></li>
                    <li><a href="/nba" itemprop="url">NBA</a></li>
                    <li><a href="/nfl" itemprop="url">NFL</a></li>
                    <li><a href="/cricket" itemprop="url">Cricket</a></li>
                    <li><a href="/mlb" itemprop="url">MLB</a></li>
                    <li><a href="/golf" itemprop="url">Golf</a></li>
                    <li><a href="/athletics" itemprop="url">Athletics</a></li>
                    <li><a href="/snooker" itemprop="url">Snooker</a></li>
                    <li><a href="/mls" itemprop="url">MLS</a></li>
                    <li><a href="/winter-sports" itemprop="url">Winter Sports</a></li>
                    <li><a href="/rugby-union" itemprop="url">Rugby</a></li>
                    <li><a href="/olympics" itemprop="url">Olympics</a></li>
            </ul>
        </div>
    </div>
</nav>

    <nav class="gms-main-sub-nav" id="gms-main-sub-nav" itemscope itemtype="http://schema.org/SiteNavigationElement">
    <div class="gms-max">
        <ul class="gms-inline-nav" onscroll="gms.updateSubNavPos()">
                    <li><a href="/giveaways" itemprop="url" target="_self" onkeyup="gms.updateSubNavPos()">Giveaways</a></li>
                    <li><a href="/1764987-ufc-270-date-fight-card-tickets-location-rumors-uk-start-time-and-everything-you-need-to-know" itemprop="url" target="_self" onkeyup="gms.updateSubNavPos()">Francis Ngannou vs Ciryl Gane</a></li>
                    <li><a href="/womens-sport" itemprop="url" target="_self" onkeyup="gms.updateSubNavPos()">Women&#x27;s Sport</a></li>
                    <li><a href="/the-football-terrace" itemprop="url" target="_self" onkeyup="gms.updateSubNavPos()">Football Terrace</a></li>
                    <li><a href="/fantasy" itemprop="url" target="_self" onkeyup="gms.updateSubNavPos()">Fantasy</a></li>
                    <li><a href="/fan-awards" itemprop="url" target="_self" onkeyup="gms.updateSubNavPos()">Fan Awards</a></li>
                    <li onfocus="gms.updateSubNavPos()" onmouseover="gms.updateSubNavPos()" onselect="gms.updateSubNavPos()" onkeyup="gms.updateSubNavPos()" class="has-dropdown">
                        <a href="#" itemprop="url">Podcast</a><div class="arrow-down"></div>
                        <ul class="dropdown">
                                <li><a href="/podcast" itemprop="url" target="_self">The High Performance Podcast</a></li>
                        </ul>
                    </li>
        </ul>
    </div>
</nav>
</header>
        <div class="gms-body gms-max">
            
            <div class="gms-ad gms-billboard" id="gms-ad-711580211-5"></div>
        <script>(function(a){a({dfp:"111_GiveMeSport_Landscape_Editorial_Top",id:"gms-ad-711580211-5",sizes:[[970,250],[728,90]]});}(this.gms.advert));</script>


            

<link rel="preload" href="https://widgets.snack-projects.co.uk/gms/quizstyle.min.css?v=2020052901" as="style" onload="this.onload = null; this.rel = 'stylesheet';">
<noscript><link rel="stylesheet" href="https://widgets.snack-projects.co.uk/gms/quizstyle.min.css?v=2020052901"></noscript>


<main class="gms-main gms-cols-f-f">
    <div class="gms-col-fluid">
        <header class="gms-section-head gms-collapsible-head" itemscope itemtype="http://schema.org/SiteNavigationElement">
    <strong class="gms-section-title"><a href="/football" itemprop="url">Football</a></strong>
        <span class="gms-collapsible-ctrl"></span>
        <nav class="gms-section-nav">
            <ul class="gms-inline-nav">
                    <li><a href="/football/latest-news" itemprop="url" class="">News</a></li>
                    <li><a href="/transfer-rumours" itemprop="url" class="">Transfers</a></li>
                    <li><a href="/football/fixtures" itemprop="url" class="">Results &amp; Fixtures</a></li>
                    <li><a href="/football/table" itemprop="url" class="">Tables</a></li>
                    <li><a href="/football/video-gallery" itemprop="url" class="">Video</a></li>
                    <li><a href="/football/directory" itemprop="url" class="">Popular Pages</a></li>
                    <li><a href="/football/quizzes" itemprop="url" class="">Quizzes</a></li>
            </ul>
        </nav>
</header>

        <nav class="gms-breadcrumb-nav">
    <ul itemscope itemtype="http://schema.org/BreadcrumbList">
            <li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
                <meta itemprop="position" content="1" />
                <a itemprop="item" href="/football"><span itemprop="name">Football</span></a>
            </li>
    </ul>
</nav>

        <article>
            <header class="gms-content-area gms-content-head">
                <h1 class="gms-content-headline">Jamie Carragher: Liverpool legend called YouTuber a &#x27;stupid little p***k&#x27; after brutal tackle</h1>
                <ul class="gms-content-inarticle-details">
                        <li class="gms-author-avatar" ><img src="https://site-cdn.givemesport.com/images/21/01/21/cd11b14301213f831c3ecbf6ff143abc/90.jpg" alt="Danny Ryan" /></li>
    <li class="gms-content-author">By&nbsp;<a href="/danny-ryan" rel="author" title="Danny Ryan">Danny Ryan</a></li>

                    <li class="gms-content-inarticle-dates">
                            <div class="gms-content-inarticle-date">
                                <time datetime="2022-01-12 13:43:09Z"><span>Published: </span>12 Jan 2022, 13:43</time>
                            </div>
                    </li>
                </ul>
                <ul class="gms-share">
    <li>
        <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle" class="gms-facebook" rel="nofollow noreferrer noopener" target="_blank">share on Facebook</a>
    </li>
    <li>
        <a href="https://twitter.com/share?url=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle&amp;amp;text=Jamie%20Carragher:%20Liverpool%20legend%20called%20YouTuber%20a%20&#x27;stupid%20little%20p***k&#x27;%20after%20brutal%20tackle" class="gms-twitter" rel="nofollow noreferrer noopener" target="_blank">share on Twitter</a>
    </li>
    <li data-platform="web">
        <a href="https://web.whatsapp.com/send?text=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle" class="gms-whatsapp" rel="nofollow noreferrer noopener" target="_blank">share on WhatsApp</a>
    </li>
    <li data-platform="mobile">
        <a href="whatsapp://send?text=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle" class="gms-whatsapp" rel="nofollow noreferrer noopener" target="_blank">share on WhatsApp</a>
    </li>
    <li>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle&amp;title=Jamie%20Carragher:%20Liverpool%20legend%20called%20YouTuber%20a%20&#x27;stupid%20little%20p***k&#x27;%20after%20brutal%20tackle" class="gms-linkedin" rel="nofollow noreferrer noopener" target="_blank">share on Linkedin</a>
    </li>
    <li>
        <a href="https://share.flipboard.com/bookmarklet/popout?v=2&amp;url=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle&amp;title=Jamie%20Carragher:%20Liverpool%20legend%20called%20YouTuber%20a%20&#x27;stupid%20little%20p***k&#x27;%20after%20brutal%20tackle" class="gms-flipboard" rel="nofollow noreferrer noopener" target="_blank">share on Flipboard</a>
    </li>
    <li data-platform="mobile">
        <a href="fb-messenger://share/?link=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle&amp;app_id=112285998808712" class="gms-messenger" rel="nofollow noreferrer noopener">share on Messenger</a>
    </li>
    <li>
        <a href="mailto:?body=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle&amp;amp;subject=Jamie%20Carragher:%20Liverpool%20legend%20called%20YouTuber%20a%20&#x27;stupid%20little%20p***k&#x27;%20after%20brutal%20tackle" class="gms-email" rel="nofollow noreferrer noopener">share on Email</a>
    </li>
</ul>
            </header>
<picture class="gms-content-media">
        <source media="(min-width: 651px)" srcset="https://site-cdn.givemesport.com/images/22/01/12/39b8be12fe7190f9166efecc7704ef7b/960.jpg">
        
        
        
        
        <source media="(min-width: 420px)" srcset="https://site-cdn.givemesport.com/images/22/01/12/39b8be12fe7190f9166efecc7704ef7b/650.jpg">
        
        
        
        
        <source media="(min-width: 321px)" srcset="https://site-cdn.givemesport.com/images/22/01/12/39b8be12fe7190f9166efecc7704ef7b/419.jpg">
        
        
        
        
        <source media="(max-width: 320px)" srcset="https://site-cdn.givemesport.com/images/22/01/12/39b8be12fe7190f9166efecc7704ef7b/320.jpg">
        
        
        
        
        
        
        
        
    <img src="https://site-cdn.givemesport.com/images/22/01/12/39b8be12fe7190f9166efecc7704ef7b/320.jpg" alt="Jamie Carragher&#x27;s tackle on Joe Weller was rather brutal..." width="320" height="207">
</picture>


<div class="newsletter-signup">
	<h3>Sign up to our FREE newsletter</h3>
	<form class="newsletter-signup-form">
		<div class="newsletter-signup-container">
			<input type="email" name="email" placeholder="Enter your email here" required>
			<button class="newsletter-subscribe">Subscribe</button>
		</div>
		<div class="newsletter-message"></div>
		<div class="newsletter-error"></div>
		<p class="newsletter-info">Once you have subscribed we will use the email you provided to send you the newsletter. You can unsubscribe at any time by clicking the unsubscribe link at the bottom of the newsletter email.</p>
		<input class="newsletter-checkbox" type="checkbox" name="consent" required>
		<label class="newsletter-label" for="consent">By ticking this box you are agreeing to our <a href="https://www.givemesport.com/terms-and-conditions" target="_blank">terms</a> and <a href="https://www.givemesport.com/privacy-policy" target="_blank">privacy policy</a></label>
	</form>
</div>
            <div class="gms-content-wrapper gms-content-area gms-content-body gms-content-intro">

                <p>In 2016, <a href="/jamie-carragher" target="_blank"><em><strong>Jamie Carragher</strong></em></a> caused a bit of a stir in a charity match at Wembley Stadium.</p>
<p>The game was played between Spencer FC and Weller Wanderers, with both teams made up of various vloggers, retired professional footballers and other online celebrities.</p>
<p>Prior to the match, which was known as the EE Wembley Cup, YouTube sensation Joe Weller poked fun at Carragher on Twitter and the <a href="/liverpool" target="_blank"><strong>Liverpool</strong></a> legend decided to take matters into his own hands during the game itself.</p>
<script>
    (function (g, v) {
        g[v] = g[v] || {};
        g[v].config = g[v].config || {};
        g[v].config["player_637775929879431243"] = {
            loc: "AEV",
            playlist: [{"Id":0,"Position":0,"Title":"WATCH: Breakdown Of Total Transfer and Wage Spend Since The Start Of The Premier League","File":"https://video-cdn.givemesport.com/video/22/01/10/cms/95e0655682c441e983d28c06e7d86084/flash/mq/640x360/95e0655682c441e983d28c06e7d86084.mp4","Image":"https://site-cdn.givemesport.com/images/22/01/10/9dc34ee380203a68d63a41c5fb812ce7/960.jpg","Width":0,"Height":0},{"Id":0,"Position":0,"Title":"WATCH: Which Premier League Club Has Made The Most From Player Sales?","File":"https://video-cdn.givemesport.com/video/22/01/10/cms/8f934c89d2c247b9bb0669678ce4387a/flash/mq/640x360/8f934c89d2c247b9bb0669678ce4387a.mp4","Image":"https://site-cdn.givemesport.com/images/22/01/10/f27b562340b0f09d4f2e297b2332b247/960.jpg","Width":0,"Height":0},{"Id":0,"Position":0,"Title":"WATCH: Premier League Top 6 Financial Breakdown 2010 - 2020","File":"https://video-cdn.givemesport.com/video/22/01/10/cms/f4ea1183ea4d4727ab3662f47f9d66f5/flash/mq/640x360/f4ea1183ea4d4727ab3662f47f9d66f5.mp4","Image":"https://site-cdn.givemesport.com/images/22/01/10/ba0fbd5cfa31f4a179c4e398a8a2f4c6/960.jpg","Width":0,"Height":0},{"Id":0,"Position":0,"Title":"WATCH: Eric Dier On His Time At Everton & Moving To Sporting | High Performance Podcast","File":"https://video-cdn.givemesport.com/video/22/01/07/cms/6e87507a56524c58a7016789390c6970/flash/mq/640x360/6e87507a56524c58a7016789390c6970.mp4","Image":"https://site-cdn.givemesport.com/images/22/01/07/b1215104a75b0048fbd06c4e2d660d34/960.jpg","Width":0,"Height":0}]
        };
    }(this.gms, "video"));
</script>
<div class="gms-video-container">
    <div class="gms-video-screen">
        <video id="player_637775929879431243" class="gms-video-player" playsinline="" muted="" autoplay=""></video>
    </div>
</div>
<p>When the pair challenged for the ball in the 56th-minute of the 'friendly' encounter, Carragher planted his studs into Weller's thigh with a rather brutal high tackle.</p><div class="gms-ad gms-ad-lazy gms-outstream" id="gms-ad-711578863-1" data-dfp="199_Desktop_Outstream_Video" data-sizes="[[648,480],[300,250]]" style="height: 480px;"></div>
<p>To rub salt in the wounds, the defender-turned-pundit turned around and called his stricken opponent a "stupid little p***k"...</p>
<h2>Video: Carragher vs Weller at Wembley</h2>
<div class="gms-media gms-twitter" data-id="771850241259802625" data-type="twitter"></div>
<p>Ouch.</p>
<p>In a video posted to his official YouTube channel after the match's conclusion, Weller called out Carragher for his reckless antics and even told him to "grow up".</p>
<h2>Video: Weller's response to Carragher after the game</h2>
<div class="gms-media gms-youtube" data-type="youtube"><iframe data-url="https://www.youtube.com/embed/y3WrqbPLyBo"></iframe></div>
<p>Weller said:&nbsp;"Fair enough, for the majority of the game I was in his back pocket. He's a professional footballer who played in the Premier League two seasons ago!</p>
<p>"But mate, why are you elbowing people in the face?&nbsp;And just kicking me?!&nbsp;What are you doing?</p>
<p>"When he did foul us, he would never say sorry or show an ounce of class, he would call us a 'f****** stupid little p****'.</p>
<p>"I mean, a 40-year-old bloke! What are you doing? Just grow up!"</p>
    <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 481px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/9e190037104b4528542cc63c144c4c4a/690.jpg">
            
            
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 480px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/9e190037104b4528542cc63c144c4c4a/480.jpg">
            
            
        <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/22/01/12/9e190037104b4528542cc63c144c4c4a/690.jpg" alt="GMS Giveaway" width="690" height="690">
    </picture>

<p><a href="/1802486-were-giving-away-500-worth-of-givemesport-merchandise" target="_blank"><strong>ENTER GIVEAWAY</strong></a></p>
<p>That was far from the end of the spat between the pair, though.</p>
<p>A few months after Weller's video went live, Carragher was asked about the infamous tackle on the YouTuber in a&nbsp;Snapchat Q&amp;A session with Soccer AM and his response was just as savage as the actual challenge.</p>
<h2>Video: Carragher's reply when asked about tackle on Weller</h2>
<div class="gms-media gms-youtube" data-type="youtube"><iframe data-url="https://www.youtube.com/embed/rga6Q3NZC60?start=174"></iframe></div>
<p>Carragher said: "He was just annoying me in the game, I'd never heard of him, supposedly a big star on YouTube, he was acting the 'big star' on the pitch, so I gave him a slap.</p>
<p>"I loved munching Joe Weller in that game and if I get a chance I'll be doing it again."</p>
<p>It was certainly a strange feud, but it was also rather hilarious one.</p>
<h2><em>The ultimate football quiz of 2021</em></h2>
<div id="quiz-container-1806081" class="sc-quiz" data-progress="1" data-total-questions="20" data-quiz-id="1806081" data-quiz-url="/1806081-the-ultimate-football-quiz-of-2021" data-question-id="1806081_1" data-trailing-slash="0">
    <form class="sc-quiz__form" action="/1806081-the-ultimate-football-quiz-of-2021/quiz-page/2" method="post">
        <div class="sc-quiz__progress-bar-wrap">
            <div class="progress">
                <div class="progress-bar sc-quiz__progress-bar" role="progressbar" aria-valuenow="0" aria-valuemin="1" aria-valuemax="" style="width:5%;">1 of 20</div>
            </div>
        </div>
        <div class="sc-quiz__inner-wrap">
            <span class="sc-quiz__image-wrap">
                <picture class="gms-content-media sc-quiz__image">
                    <source srcset="https://site-cdn.givemesport.com/images/21/12/21/277e59fca0ee791acf7c2c6a160261b4/960.jpg" media="(min-width: 651px)" data-srcset="/1806081-the-ultimate-football-quiz-of-2021960.jpg">
                    
                    
                    
                    
                    <source srcset="https://site-cdn.givemesport.com/images/21/12/21/277e59fca0ee791acf7c2c6a160261b4/650.jpg" media="(min-width: 420px)" data-srcset="/1806081-the-ultimate-football-quiz-of-2021650.jpg">
                    
                    
                    
                    
                    
                    
                    
                    
                    
                    <source srcset="https://site-cdn.givemesport.com/images/21/12/21/277e59fca0ee791acf7c2c6a160261b4/320.jpg" media="(max-width: 320px)" data-srcset="/1806081-the-ultimate-football-quiz-of-2021320.jpg">
                    
                    
                    
                    
                    
                    
                    
                    
                <img src="https://site-cdn.givemesport.com/images/21/12/21/277e59fca0ee791acf7c2c6a160261b4/650.jpg" alt="p1fne6dl9imjhkjs1f5q3jl1pi93.jpg" width="650" height="420">
                </picture>
            </span>
            <h3 class="sc-quiz__question">Cristiano Ronaldo and which other player scored five goals at Euro 2020?</h3>
            <div class="sc-quiz__answers-wrap">
                <button class="sc-quiz__answer" value="1" data-correct-answer="4" title="Romelu Lukaku" disabled="">
                    Romelu Lukaku
                </button>
                <button class="sc-quiz__answer" value="2" data-correct-answer="4" title="Emil Forsberg" disabled="">
                    Emil Forsberg
                </button>
                <button class="sc-quiz__answer" value="3" data-correct-answer="4" title="Karim Benzema" disabled="">
                    Karim Benzema
                </button>
                <button class="sc-quiz__answer" value="4" data-correct-answer="4" title="Patrik Schick" disabled="">
                    Patrik Schick
                </button>
            </div>
        </div>
    </form>
    <div class="sc-quiz__divider"></div>
</div>

                <ul class="gms-content-tags" itemscope itemtype="http://schema.org/SiteNavigationElement">
        <li><a href="/football" itemprop="url">Football</a></li>
        <li><a href="/quiz" itemprop="url">Quiz</a></li>
</ul>

                <nav class="gms-circulation">
    <a href="/1818583-tottenham-transfer-news-make-or-break-major-claim-emerges-on-64-spurs-stars-future?utm_source=navigation-next&amp;utm_medium=internal" class="gms-next">next story</a>
    
</nav>
                    <div style="margin-top: 1rem;"></div>
                    <script id="fan-awards" type="text/javascript" src="https://fan-awards.snack-projects.co.uk/widget/embed-scheduled.js" defer></script>
                <a href="https://www.newsnow.co.uk/h/Sport" title="Click here for more Sport news from NewsNow" rel="nofollow noopener" target="_blank" class="gms-newsnow">
                    <span>News Now - Sport News</span>
                </a>
            </div>

            <footer class="gms-content-area gms-content-foot">
                <ul class="gms-share">
    <li>
        <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle" class="gms-facebook" rel="nofollow noreferrer noopener" target="_blank">share on Facebook</a>
    </li>
    <li>
        <a href="https://twitter.com/share?url=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle&amp;amp;text=Jamie%20Carragher:%20Liverpool%20legend%20called%20YouTuber%20a%20&#x27;stupid%20little%20p***k&#x27;%20after%20brutal%20tackle" class="gms-twitter" rel="nofollow noreferrer noopener" target="_blank">share on Twitter</a>
    </li>
    <li data-platform="web">
        <a href="https://web.whatsapp.com/send?text=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle" class="gms-whatsapp" rel="nofollow noreferrer noopener" target="_blank">share on WhatsApp</a>
    </li>
    <li data-platform="mobile">
        <a href="whatsapp://send?text=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle" class="gms-whatsapp" rel="nofollow noreferrer noopener" target="_blank">share on WhatsApp</a>
    </li>
    <li>
        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle&amp;title=Jamie%20Carragher:%20Liverpool%20legend%20called%20YouTuber%20a%20&#x27;stupid%20little%20p***k&#x27;%20after%20brutal%20tackle" class="gms-linkedin" rel="nofollow noreferrer noopener" target="_blank">share on Linkedin</a>
    </li>
    <li>
        <a href="https://share.flipboard.com/bookmarklet/popout?v=2&amp;url=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle&amp;title=Jamie%20Carragher:%20Liverpool%20legend%20called%20YouTuber%20a%20&#x27;stupid%20little%20p***k&#x27;%20after%20brutal%20tackle" class="gms-flipboard" rel="nofollow noreferrer noopener" target="_blank">share on Flipboard</a>
    </li>
    <li data-platform="mobile">
        <a href="fb-messenger://share/?link=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle&amp;app_id=112285998808712" class="gms-messenger" rel="nofollow noreferrer noopener">share on Messenger</a>
    </li>
    <li>
        <a href="mailto:?body=https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle&amp;amp;subject=Jamie%20Carragher:%20Liverpool%20legend%20called%20YouTuber%20a%20&#x27;stupid%20little%20p***k&#x27;%20after%20brutal%20tackle" class="gms-email" rel="nofollow noreferrer noopener">share on Email</a>
    </li>
</ul>
                    <div id="taboola-below-article-thumbnails-1" class="gms-syndication"></div>
<aside class="gms-group gms-related-list">
    <h2 class="gms-group-head">Related articles</h2>
        <div class="gms-teaser">
            <a href="/1815994-jamie-carragher-takes-part-in-twitter-qa-a-roundup-of-his-best-answers?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories" title="Jamie Carragher has done a Q&amp;A on Twitter - here are some of his best answers" class="gms-teaser-image">
                
                <picture class="gms-lazy-image">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/08/3677be0f878890b48712e893afef0b49/419.jpg">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/08/3677be0f878890b48712e893afef0b49/144.jpg">
                    <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/22/01/08/3677be0f878890b48712e893afef0b49/320.jpg" alt="Jamie Carragher" width="480" height="310">
                </picture>
            </a>
            <div class="gms-teaser-content">
                <h3 class="gms-teaser-title"><a href="/1815994-jamie-carragher-takes-part-in-twitter-qa-a-roundup-of-his-best-answers?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories">Jamie Carragher has done a Q&amp;A on Twitter - here are some of his best answers</a></h3>
            </div>
        </div>
        <div class="gms-teaser">
            <a href="/1818128-andy-carroll-reading-striker-scored-two-incredible-disallowed-goals-vs-fulham?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories" title="Andy Carroll scored two of the greatest ever disallowed goals in the space of 60 secs v Fulham" class="gms-teaser-image">
                
                <picture class="gms-lazy-image">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/11/be624a4c32618125619dcddd68903763/419.jpg">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/11/be624a4c32618125619dcddd68903763/144.jpg">
                    <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/22/01/11/be624a4c32618125619dcddd68903763/320.jpg" alt="Absolutely incredible..." width="480" height="310">
                </picture>
            </a>
            <div class="gms-teaser-content">
                <h3 class="gms-teaser-title"><a href="/1818128-andy-carroll-reading-striker-scored-two-incredible-disallowed-goals-vs-fulham?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories">Andy Carroll scored two of the greatest ever disallowed goals in the space of 60 secs v Fulham</a></h3>
            </div>
        </div>
        <div class="gms-teaser">
            <a href="/1818158-afcon-mohamed-kamaras-unique-highlights-for-sierra-leone-vs-algeria-have-gone-viral?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories" title="Sierra Leone GK&#x27;s highlights from MOTM display v Algeria are so unique they&#x27;ve gone viral" class="gms-teaser-image">
                
                <picture class="gms-lazy-image">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/a5d2cab7a624b9fb6285117da8e3b538/419.jpg">
                    <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/a5d2cab7a624b9fb6285117da8e3b538/144.jpg">
                    <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/22/01/12/a5d2cab7a624b9fb6285117da8e3b538/320.jpg" alt="What a performance by Mohamed Kamara!" width="480" height="310">
                </picture>
            </a>
            <div class="gms-teaser-content">
                <h3 class="gms-teaser-title"><a href="/1818158-afcon-mohamed-kamaras-unique-highlights-for-sierra-leone-vs-algeria-have-gone-viral?utm_source=thumbnail&utm_medium=internal&utm_campaign=related-stories">Sierra Leone GK&#x27;s highlights from MOTM display v Algeria are so unique they&#x27;ve gone viral</a></h3>
            </div>
        </div>
</aside>                <div class="gms-profile gms-profile-border">
    <a href="/danny-ryan" title="Danny Ryan" class="gms-profile-image">
        <picture class="gms-lazy-image">
            <img src="https://site-cdn.givemesport.com/content/img/gms-default-avatar.png" data-src="https://site-cdn.givemesport.com/images/21/01/21/cd11b14301213f831c3ecbf6ff143abc/90.jpg" alt="Danny Ryan">
        </picture>
    </a>
    <div class="gms-profile-content">
        <strong class="gms-profile-head">
            Danny Ryan
        </strong>
        <h3 class="gms-profile-title">Interested in: Arsenal, Barcelona, Boxing</h3>
        <div class="gms-content-details gms-profile-details"><p>Danny Ryan is a Senior Writer and Boxing Lead at GiveMeSport.&nbsp;He's had the pleasure of interviewing the likes of Tyson Fury, Gary Lineker, Amir Khan, Lennox Lewis, Joe Root, David Haye, Frank Warren, Kell Brook &amp; Joseph Parker. He once got Eoin Morgan to commentate on THAT Super Over and is an above average FIFA player.</p></div>
        <ul class="gms-share" style="color: #FFF;">
            
            <li>
                <a href="https://twitter.com/@DannyRyan94" class="gms-twitter" rel="nofollow noreferrer noopener" target="_blank">Twitter</a>
            </li>
        </ul>
    </div>
</div>
            </footer>
        </article>
    </div>
    <aside class="gms-col-fixed">

        
        <section class="gms-group gms-group-accent">
    <h2 class="gms-group-head">Trending Football Stories</h2>
    <ol class="gms-trending">
            <li><a href="/1751708-zlatan-ibrahimovic-scores-minutes-after-coming-onto-the-pitch-after-4month-absence">Zlatan Ibrahimovic scores minutes after coming onto the pitch after 4-month absence </a></li>
            <li><a href="/1751749-harvey-elliott-liverpool-youngsters-classy-gesture-to-fan-in-hospital-after-injury-vs-leeds">Harvey Elliott: Liverpool youngster&#x27;s classy gesture to fan in hospital after injury vs Leeds</a></li>
            <li><a href="/1751741-harvey-elliott-liverpools-jurgen-klopp-was-visibly-emotional-when-giving-injury-update">Harvey Elliott: Liverpool&#x27;s Jurgen Klopp was visibly emotional when giving injury update </a></li>
            <li><a href="/1751729-harvey-elliott-injury-man-utds-marcus-rashford-sends-classy-to-liverpool-star">Harvey Elliott Injury: Man Utd&#x27;s Marcus Rashford sends classy to Liverpool star </a></li>
    </ol>
</section>
        
                <div class="gms-ad gms-ad-lazy gms-mpu" id="gms-ad-711580214-6" data-dfp="112_GiveMeSport_Portrait_Editorial_Right" data-sizes="[[300,600],[300,250]]"></div>

        
        <section class="gms-group">
            <h2 class="gms-group-head"><a href="/football/latest-news">Latest Football articles</a></h2>
<div class="gms-teaser">
    <a href="/1754870-january-transfer-window-2022-when-does-it-open-when-does-it-close-and-which-players-are-going-to-move" title="January Transfer Window 2022: Rumours, Deadline and Everything You Need to Know" class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/3fd0e8ffadffe56510485bea2894c047/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/3fd0e8ffadffe56510485bea2894c047/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/22/01/12/3fd0e8ffadffe56510485bea2894c047/320.jpg" alt="Philippe Coutinho signed for Aston Villa on loan until the end of the season." width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1754870-january-transfer-window-2022-when-does-it-open-when-does-it-close-and-which-players-are-going-to-move">January Transfer Window 2022: Rumours, Deadline and Everything You Need to Know</a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            
    <li class="gms-content-date gms-content-date-updated"><time datetime="2021-09-17T03:30:26"><span>Updated: </span>an hour ago</time></li>

        </ul>
    </div>
</div><div class="gms-teaser">
    <a href="/1818559-andy-carroll-goals-the-10-greatest-disallowed-goals-after-reading-strikers-wonder-strikes" title="Andy Carroll goals: The 10 greatest disallowed goals after Reading striker&#x2019;s wonder strikes" class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/05067a452d7eac7a8c916b085969621a/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/05067a452d7eac7a8c916b085969621a/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/22/01/12/05067a452d7eac7a8c916b085969621a/320.jpg" alt="Andy Carroll" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1818559-andy-carroll-goals-the-10-greatest-disallowed-goals-after-reading-strikers-wonder-strikes">Andy Carroll goals: The 10 greatest disallowed goals after Reading striker&#x2019;s wonder strikes</a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            
    <li class="gms-content-date"><time datetime="2022-01-12T12:54:31">an hour ago</time></li>

        </ul>
    </div>
</div><div class="gms-teaser">
    <a href="/1818437-man-utd-sir-alex-fergusons-greatest-team-talk-vs-chelsea-in-2008-champions-league-final" title="Man Utd: Sir Alex Ferguson&#x2019;s greatest team talk vs Chelsea in 2008 Champions League final" class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/a9a3b97c41e56603dc6d3c4c46b5e745/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/a9a3b97c41e56603dc6d3c4c46b5e745/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/22/01/12/a9a3b97c41e56603dc6d3c4c46b5e745/320.jpg" alt="Sir Alex Ferguson reserved his greatest Man Utd team talk for the 2008 Champions League final" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1818437-man-utd-sir-alex-fergusons-greatest-team-talk-vs-chelsea-in-2008-champions-league-final">Man Utd: Sir Alex Ferguson&#x2019;s greatest team talk vs Chelsea in 2008 Champions League final</a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            
    <li class="gms-content-date"><time datetime="2022-01-12T12:02:23">2 hours ago</time></li>

        </ul>
    </div>
</div><div class="gms-teaser">
    <a href="/1818392-inter-milan-vs-juventus-live-stream-how-to-watch-team-news-head-to-head-odds-prediction-and-everything-you-need-to-know" title="Inter Milan vs Juventus Live Stream: How to Watch, Team News, Head to Head, Odds, Prediction and Everything You Need to Know" class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/e8b2a5b8fb4176efb6716c718720a3f2/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/e8b2a5b8fb4176efb6716c718720a3f2/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/22/01/12/e8b2a5b8fb4176efb6716c718720a3f2/320.jpg" alt="Inter Milan vs Juventus Live Stream: How to Watch, Team News, Head to Head, Odds, Prediction and Everything You Need to Know" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1818392-inter-milan-vs-juventus-live-stream-how-to-watch-team-news-head-to-head-odds-prediction-and-everything-you-need-to-know">Inter Milan vs Juventus Live Stream: How to Watch, Team News, Head to Head, Odds, Prediction and Everything You Need to Know</a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            
    <li class="gms-content-date"><time datetime="2022-01-12T11:38:00">2 hours ago</time></li>

        </ul>
    </div>
</div><div class="gms-teaser">
    <a href="/1818357-man-uniteds-class-of-2011-were-named-the-next-busby-babes-but-where-are-they-now" title="Man United&#x27;s Class of 2011 were named &#x2018;the next Busby Babes&#x2019; - but where are they now?" class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/32df6c05cc7101dc9b90a21d2d5ff205/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/32df6c05cc7101dc9b90a21d2d5ff205/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/22/01/12/32df6c05cc7101dc9b90a21d2d5ff205/320.jpg" alt="Man Utd" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1818357-man-uniteds-class-of-2011-were-named-the-next-busby-babes-but-where-are-they-now">Man United&#x27;s Class of 2011 were named &#x2018;the next Busby Babes&#x2019; - but where are they now?</a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            
    <li class="gms-content-date"><time datetime="2022-01-12T11:15:28">2 hours ago</time></li>

        </ul>
    </div>
</div><div class="gms-teaser">
    <a href="/1818338-vivianne-miedema-should-arsenals-star-striker-stick-or-twist-with-the-gunners" title="Vivianne Miedema: Should Arsenal&#x27;s star striker stick or twist with the Gunners?" class="gms-teaser-image">
        
        <picture class="gms-lazy-image">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(min-width: 769px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/fa30647ad8c7870da0e8ca609c71da0a/419.jpg">
            <source srcset="https://site-cdn.givemesport.com/v4/images/stub.svg" media="(max-width: 768px)" data-srcset="https://site-cdn.givemesport.com/images/22/01/12/fa30647ad8c7870da0e8ca609c71da0a/144.jpg">
            <img src="https://site-cdn.givemesport.com/v4/images/stub.svg" data-src="https://site-cdn.givemesport.com/images/22/01/12/fa30647ad8c7870da0e8ca609c71da0a/320.jpg" alt="Should Arsenal Women&#x27;s star striker Vivianne Miedema stick with the Gunners or move away?" width="480" height="310">
        </picture>
    </a>
    <div class="gms-teaser-content">
        <h3 class="gms-teaser-title"><a href="/1818338-vivianne-miedema-should-arsenals-star-striker-stick-or-twist-with-the-gunners">Vivianne Miedema: Should Arsenal&#x27;s star striker stick or twist with the Gunners?</a></h3>
        <ul class="gms-content-details gms-teaser-details">
            <li><a href="/football">Football</a></li>
            
    <li class="gms-content-date"><time datetime="2022-01-12T11:00:58">3 hours ago</time></li>

        </ul>
    </div>
</div>            <footer class="gms-group-foot">
                <a href="/football/latest-news">More Football news</a>
            </footer>
        </section>
                <div class="gms-ad gms-ad-lazy gms-mpu" id="gms-ad-711580217-7" data-dfp="113_GiveMeSport_Portrait_Editorial_Right" data-sizes="[[300,600],[300,250]]"></div>

    </aside>
</main>
        </div>
        <footer class="gms-site-footer">
    <div class="gms-max">
        <a href="/" class="gms-logo gms-logo-default">GiveMeSport</a>
        <ul class="gms-site-footer-nav" itemscope itemtype="http://schema.org/SiteNavigationElement">
            <li><a href="/about" itemprop="url">About</a></li>
            <li><a href="/our-writers" itemprop="url">Our Writers</a></li>
            <li><a href="/privacy-policy" itemprop="url">Privacy</a></li>
            <li><a href="/legal" itemprop="url">Legal</a></li>
            <li><a href="/accessibility" itemprop="url">Accessibility</a></li>
            <li><a href="/cookies-policy" itemprop="url">Cookies</a></li>
            <li><a href="/terms-and-conditions" itemprop="url">Terms</a></li>
            <li><a href="/sponsored-content" itemprop="url">Sponsored</a></li>
            <li><a href="/academy" itemprop="url">Academy</a></li>
            <li><a href="/contact-us" itemprop="url">Contact</a></li>
        </ul>
        <ul class="gms-social-links">
    <li><a href="https://www.facebook.com/GiveMeSport" target="_blank" rel="noopener" class="gms-facebook" title="Follow us on Facebook">Facebook</a></li>
    <li><a href="https://twitter.com/GiveMeSport" target="_blank" rel="noopener" class="gms-twitter" title="Follow us on Twitter">Twitter</a></li>
    <li><a href="https://www.youtube.com/user/GiveMeSport" target="_blank" rel="noopener" class="gms-youtube" title="Follow us on YouTube">YouTube</a></li>
    <li><a href="https://www.instagram.com/givemesport" target="_blank" rel="noopener" class="gms-instagram" title="Follow us on Instagram">Instagram</a></li>
</ul>
        <p class="gms-site-copyright">&copy; 2022 Sports New Media Limited. All Rights Reserved.</p>
    </div>
</footer>
    </div>
            <div class="gms-ad gms-interstitial" id="gms-ad-711580158-2"></div>
        <script>(function(a){a({dfp:"100_GiveMeSport_Out-of-page",id:"gms-ad-711580158-2",sizes:[]});}(this.gms.advert));</script>

    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle"
    },
    "headline": "Jamie Carragher: Liverpool legend called YouTuber a 'stupid little p***k' after brutal tackle",
    "datePublished": "2022-01-12T13:43:09.8950000Z",
    "dateModified": "2022-01-12T13:43:09.8950000Z",
    "description": "Jamie Carragher: Liverpool legend called YouTuber a 'stupid little p***k' after brutal tackle",
    "author": {
        "@type": "Person",
        "name": "Danny Ryan",
        "sameAs": "https://www.givemesport.com/danny-ryan"
    },
    "publisher": {
        "@type": "Organization",
        "url": "https://www.givemesport.com",
        "name": "GiveMeSport",
        "logo": {
            "@type": "ImageObject",
            "url": "https://site-cdn.givemesport.com/v4/images/logo-gms-black.png"
        }
    },
    "thumbnailUrl": "https://site-cdn.givemesport.com/images/22/01/12/39b8be12fe7190f9166efecc7704ef7b/144.jpg",
    "creator": ["Danny Ryan"],
    "keywords": ["Football","Quiz"],
    "articleSection": "Football",
    "url": "https://www.givemesport.com/1818620-jamie-carragher-liverpool-legend-called-youtuber-a-stupid-little-pk-after-brutal-tackle",
    "image": ["https://site-cdn.givemesport.com/images/22/01/12/95e218230093df78294cde1898449240/1216.jpg","https://site-cdn.givemesport.com/images/22/01/12/95e218230093df78294cde1898449240/1204.jpg","https://site-cdn.givemesport.com/images/22/01/12/95e218230093df78294cde1898449240/1201.jpg"]    }
</script>

        <script defer src="https://snack-scripts.b-cdn.net/tft/ticker/tft-ticker.js"></script>
    <noscript class="gms-no-script">
        <img src="//www.facebook.com/tr?id=1762069164047152&ev=PageView&noscript=1" height="1" width="1" alt="">
        <img src="//certify.alexametrics.com/atrk.gif?account=zRWAh1aAod00ah" height="1" width="1" alt="">
        <img src="//b.scorecardresearch.com/p?c1=2&amp;c2=&amp;c3=&amp;c4=&amp;c5=&amp;c6=&amp;c15=&amp;cv=2.0&amp;cj=1" height="1" width="1" alt="">
        <div style="display:none;">
            <img src="//pixel.quantserve.com/pixel/p-0Q_T1ja8r-Dkk.gif" border="0" height="1" width="1" alt="Quantcast"/>
        </div>
    </noscript>
</body>
</html>